package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Birthday\s*(.*)Age`)
var str = `Sample 3
Birthday April 4, 1994 Age 27 years old
Gender Male`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}