re = /Birthday\s*(.*)Age/
str = 'Sample 3
Birthday April 4, 1994 Age 27 years old
Gender Male'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end