import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([yYzZ](?!\\S))|.";
final String string = "fez day\n"
+ "day fez\n"
+ "day fyyyz\n"
+ "day yak\n"
+ "day:yak\n"
+ "!!day--yaz!!\n"
+ "yak zak\n"
+ "DAY abc XYZ\n"
+ "aaz yyz my\n"
+ "y2bz\n"
+ "zxyx\n"
+ "other tests\n"
+ "X ";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}