import Foundation
let pattern = #"([yYzZ](?!\S))|."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
fez day
day fez
day fyyyz
day yak
day:yak
!!day--yaz!!
yak zak
DAY abc XYZ
aaz yyz my
y2bz
zxyx
other tests
X
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)