package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*xyz.*$`)
var str = `1xyz-2xyz
1-2xyz
1xyz
1-2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}