$re = '/^.*xyz.*$/m';
$str = '1xyz-2xyz
1-2xyz
1xyz
1-2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);