re = /(^|\s)0\S*/m
str = '1,1,1075 1,0,39 2,4,1,22409 0,1,1,755,300 0,1,1,755,50'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end