$re = '/(?<=COMBINED TEST FOR THE PRESENCE OF CLIMATE CHANGE).*(\n.*)+(?=random)/m';
$str = 'COMBINED TEST FOR THE PRESENCE OF CLIMATE CHANGE
IDENTIFIABLE CLIMATE CHANGE PRESENT random word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);