re = /(?<=COMBINED TEST FOR THE PRESENCE OF CLIMATE CHANGE).*(\n.*)+(?=random)/m
str = 'COMBINED TEST FOR THE PRESENCE OF CLIMATE CHANGE
IDENTIFIABLE CLIMATE CHANGE PRESENT random word'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end