re = /,(?<email>[^@]*@[^,]*),/m
str = '123,s@gmail.com,abc
124,g@gmail.com,f@gmail.com,bcd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end