$re = '`[(]([^()@[:space:]]+@[^()[:space:]]+[.][^()[:space:]]+)[)]`m';
$str = 'Mark Johnson (mark@johnson.com)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);