$re = '/(\D+)([\d\.]+)(\D+.*)/m';
$str = 'Jitsi2.10.5550Windows 10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);