$re = '/"([^:]+)"(?=,|}|$)/';
$str = '{"contactForm":{"title":"Mr","firstName":"Jimmy","phonenumber":"12341234"}}';
$subst = "\"_$1_\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;