const regex = /([a-z]+(?:-[a-z]+)*):\s*(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z]+(?:-[a-z]+)*):\\s*(.+)', 'gm')
const str = `2019-03-07T02:48:17-03:00<br /><br />domain: 100anosdemusica.com.br<br />expires: 20190421<br /><br />country: BR';
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}