$re = '/\(.*\)|[^\s]+/m';
$str = 'A >= 10 AND B <= 20 OR C in (\'3\', \'4\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);