$re = '/"taskType"\s?:\s?"(doSomething|doAnotherThing)"/m';
$str = 'Logfile 1: "taskType":"doSomething"
Logfile 2: "taskType" : "doAnotherThing"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);