re = /"taskType"\s?:\s?"(doSomething|doAnotherThing)"/m
str = 'Logfile 1: "taskType":"doSomething"
Logfile 2: "taskType" : "doAnotherThing"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end