package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.(?:co\.uk|com)$`)
var str = `aol.com
amazon.co.uk`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}