$re = '`\.(?:co\.uk|com)$`m';
$str = 'aol.com
amazon.co.uk';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;