import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "cadeiras?\\s*?(perpétua|cativa)?s?\\s*?(de|com|,)?\\s*?(o)?\\s*?(número)?\\s*?(de)?\\s*?(controle)?\\s*?(inicial)?\\s*?(de)?\\s*?(números?|nº)?\\s*?(?<NUMERO_CONTROLE_CADEIRA>\\d(\\d|\\s|-|–)+)";
final String string = "1. O Autor é detentor do direito de uso de duas cadeiras perpétuas com o número de controle nº 1234-123456789 e 3421 – 11111111 (Doc. 04) do Estádio\n\n"
+ " O Autor é detentor do direito de uso de uma cadeira perpétua com o número de controle nº 4321-112223333 (Doc. 07) do Estádio Jornalista Mário Filho \n\n"
+ "cadeira perpétua com o número de controle nº 1234\n\n\n\n"
+ "cadeiras nº23 e nº24, e número de controle das cadeiras nº1.123 e 2.123 (anexo 1),\n\n\n"
+ "O Autor é titular de direito de uso de cadeira cativa e perpétua localizada no Estádio Jornalista Mário Filho (Maracanã), controle nº 4321\n\n"
+ "As Autoras são detentoras do direito de uso de uma cadeira perpétua com o número de controle nº 1234-2951497377.\n\n\n"
+ " A Autora é detentora do direito de uso de uma cadeira perpétua com o número de controle nº 1234-2947761217 (Doc. 05) \n\n\n"
+ "O autor, é titular do direito de uso de da Cadeira Cativa no Estádio\n"
+ "Jornalista Mário Filho (Maracanã) número de controle 4123456, fato este\n"
+ "que pode ser comprovado pelo documento em anexo.\n\n"
+ " sua cadeira perpétua de número de controle 123-2947741041 nas Olimpíadas e Paraolimpíadas de 2016";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}