$re = '/cadeiras?\s*?(perpétua|cativa)?s?\s*?(de|com|,)?\s*?(o)?\s*?(número)?\s*?(de)?\s*?(controle)?\s*?(inicial)?\s*?(de)?\s*?(números?|nº)?\s*?(?<NUMERO_CONTROLE_CADEIRA>\d(\d|\s|-|–)+)/m';
$str = '1. O Autor é detentor do direito de uso de duas cadeiras perpétuas com o número de controle nº 1234-123456789 e 3421 – 11111111 (Doc. 04) do Estádio
O Autor é detentor do direito de uso de uma cadeira perpétua com o número de controle nº 4321-112223333 (Doc. 07) do Estádio Jornalista Mário Filho
cadeira perpétua com o número de controle nº 1234
cadeiras nº23 e nº24, e número de controle das cadeiras nº1.123 e 2.123 (anexo 1),
O Autor é titular de direito de uso de cadeira cativa e perpétua localizada no Estádio Jornalista Mário Filho (Maracanã), controle nº 4321
As Autoras são detentoras do direito de uso de uma cadeira perpétua com o número de controle nº 1234-2951497377.
A Autora é detentora do direito de uso de uma cadeira perpétua com o número de controle nº 1234-2947761217 (Doc. 05)
O autor, é titular do direito de uso de da Cadeira Cativa no Estádio
Jornalista Mário Filho (Maracanã) número de controle 4123456, fato este
que pode ser comprovado pelo documento em anexo.
sua cadeira perpétua de número de controle 123-2947741041 nas Olimpíadas e Paraolimpíadas de 2016';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);