$re = '/^.*?(\w+\.(?:co\.uk|\w+))$/m';
$str = 'red.testurl.com
new.red.testurl.com
new.red.testurl.io
new.red.testurl.co.uk';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;