re = /^.*?(\w+\.(?:co\.uk|\w+))$/m
str = 'red.testurl.com
new.red.testurl.com
new.red.testurl.io
new.red.testurl.co.uk'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result