#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^( ?(\d+-\d++|\d+) ?,?)+$"
Local $sString = "1023342" & @CRLF & _
"1023342-1023345" & @CRLF & _
"" & @CRLF & _
"1023342-1023334" & @CRLF & _
"fish" & @CRLF & _
"1023342,fish" & @CRLF & _
"1023342-fish" & @CRLF & _
"1023342 ,1023343,1023344, 1023345" & @CRLF & _
"6888-" & @CRLF & _
"-39393" & @CRLF & _
",33" & @CRLF & _
"1023342-1023344,1023345" & @CRLF & _
"5-,200" & @CRLF & _
"3,-18" & @CRLF & _
"1023342 , 1023343-1023345" & @CRLF & _
"1023342-1023344,1023345-1023347" & @CRLF & _
"1023342-1023344,1023345-1023-347" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")