$re = '/^( ?(\d+-\d++|\d+) ?,?)+$/m';
$str = '1023342
1023342-1023345
1023342-1023334
fish
1023342,fish
1023342-fish
1023342 ,1023343,1023344, 1023345
6888-
-39393
,33
1023342-1023344,1023345
5-,200
3,-18
1023342 , 1023343-1023345
1023342-1023344,1023345-1023347
1023342-1023344,1023345-1023-347
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);