use strict;
my $str = 'correspondent à l\'ASIN B00WU8XXXX, mais les attributs suivants sont en conflit avec : product_type (Vendeur : \'APPLIANCE_ACCESSORY\' / Amazon : \'CLEANING_AGENT\'), ean (Vendeur : \'400650819XXXX\' / Amazon : \'400650819XXXX\'), item_package_quantity (Vendeur : \'5\' / Amazon : \'10\'';
my $regex = qr/(\w+) \(Vendeur : '([^']*)' \/ Amazon : '([^']*)'/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}