using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^([1-9][\d]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])\.)(((0|[1-9][0-9]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])\.){2})(0|[1-9][\d]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])$";
string input = @"1.1.1.1
10.10.10.10
255.255.255.255
1.255.1.123
0.1.1.1
1.0.0.0
1.1.1.1
255.256.255.255
127.0.0.1
.127.0.0.1
q.0.0.0
t.t.t.t
44.44.44.44
44.44.44.444
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}