re = /(\S+(?: ID)?): ([^:]+?) *(?=$|\b[^:\s]+(?: ID)?:)/m
str = 'Naam: TEST B.V. Omschrijving: Factuur 20-01-2024, klantnummer 1234567890. IBAN: NL41INGB0000467598 Kenmerk: 000011292292967 Machtiging ID: M10024815057 Incassant ID: NL39KPN271247010001 Doorlopende incasso Valutadatum: 24-01-2024'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end