$re = '/(?<=<head>).*?<(\w*.)>(.*?)(<\/\1>)(.*?)(?=<\/head>)/m';
$str = '<head><meta>asdf contents</meta></head>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);