re = /(?<=<head>).*?<(\w*.)>(.*?)(<\/\1>)(.*?)(?=<\/head>)/m
str = '<head><meta>asdf contents</meta></head>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end