$re = '/\b(?![A-Z]{7})[A-Z\d]{7}\b/m';
$str = 'I want this nr A7A3G1A but not this ANTENNA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);