using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^:]*:[^\*!]";
string input = @"foo::bar:baz:::
foo:pwd:baz:::
foo:*:bar:baz:::
foo:!:bar:baz:::
foo:!!:bar:baz:::
foo:!pwd:baz:::
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}