re = /^[^:]*:[^\*!]/m
str = 'foo::bar:baz:::
foo:pwd:baz:::
foo:*:bar:baz:::
foo:!:bar:baz:::
foo:!!:bar:baz:::
foo:!pwd:baz:::
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end