import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(?:\\s|^)(?![@#])(?!__)\\S*)_([^_]+)_";
final String string = "Test sentence:\n"
+ "_some_val #ta_g_ and _some_ value, but some_val_ and #some_tag_value and @a_mention_ and a #_tag_\n\n"
+ "Should match (between underscores)\n"
+ "----\n"
+ "_italic text here_\n"
+ "police_woman_\n"
+ "_fire_fighter\n"
+ "a thousand _words_\n"
+ "_brunch_ on a Sunday\n"
+ "match_this_and_that_\n\n"
+ "Should not match anything\n"
+ "----\n"
+ "@ta_g_\n"
+ "__value__\n"
+ "#some_tag_value\n"
+ "@some_value_here\n"
+ "@some_tag_\n"
+ "#some_val_\n"
+ "#_hello_\n"
+ "@match_this_and_that_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}