re = /(?<=(?:\s|^)(?![@#])(?!__)\S*)_([^_]+)_/m
str = 'Test sentence:
_some_val #ta_g_ and _some_ value, but some_val_ and #some_tag_value and @a_mention_ and a #_tag_
Should match (between underscores)
----
_italic text here_
police_woman_
_fire_fighter
a thousand _words_
_brunch_ on a Sunday
match_this_and_that_
Should not match anything
----
@ta_g_
__value__
#some_tag_value
@some_value_here
@some_tag_
#some_val_
#_hello_
@match_this_and_that_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end