re = /\p{L}+/m
str = '.
Regular expression
Biểu thức chính quy
Expression régulière
正则表达式'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end