import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(?:\\s*from\\s(?:(?:([^\\(\\n]*?)\\s)|(\\[[^\\]]*\\]))?(?:\\((?:(?:((?!HELO|EHLO)[^\\s]*)|(?:(?:EHLO)|(?:HELO)))?(?:[\\s\\w\\.]*(?:(?:\\[([^\\]]*)\\])|([^\\)\\s]*))\\))))?(?:\\{.*\\})?)?\n"
	 + "\\s*(?:(?:client\\s)?[\\(\\{\\[]+([^\\)\\}\\]]*)[\\)\\}\\]]+\\;?(?:\\{.*\\})?)?\n"
	 + "(?:[\\s\\n]*)\n"
	 + "(?:\\s*(?:by(?:(?:.*?)(?:\\;|(?:[\\r\\n]+))))(?!.*with))?\n"
	 + "(?:\\s*(?:by\\s[^\\;]*\\)?)(?=.*with)\\s*)?\n"
	 + "(?:with\\s*(?:((?:[^\\n;]*))(?:.*\\;)?))?\n"
	 + "(?:[\\s\\n]*)?\n"
	 + "(?:\\(?envelope-from\\s*([^\\n]*)\\;?\\)?)?\n"
	 + "(?:\\s*id[^;]*\\;?)?\n"
	 + "(?:[\\s\\n]*)?\n"
	 + "(?:for\\s([^\\;]*)\\;)?\n"
	 + "(?:[\\s\\n]*)?\n"
	 + "(?:\\(.*\\)\\;)?(?:[\\s\\n])?\n"
	 + "([^\\(]+)?\n"
	 + "(?:\\(?envelope-from\\s*([^\\n]*)\\;?\\)?)?";
        final String string = "from qzienfhr ([182.109.196.197]) by mail.oucu.edu.eg\n"
	 + "        with SMTP (Code-Crafters Ability Mail Server 2012);\n"
	 + "        Mon, 03 Dec 2018 12:42:56 +0200";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
        final Matcher matcher = pattern.matcher(string);
        
        if (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}