use strict;
my $str = 'from qzienfhr ([182.109.196.197]) by mail.oucu.edu.eg
with SMTP (Code-Crafters Ability Mail Server 2012);
Mon, 03 Dec 2018 12:42:56 +0200';
my $regex = qr/(?:\s*from\s(?:(?:([^\(\n]*?)\s)|(\[[^\]]*\]))?(?:\((?:(?:((?!HELO|EHLO)[^\s]*)|(?:(?:EHLO)|(?:HELO)))?(?:[\s\w\.]*(?:(?:\[([^\]]*)\])|([^\)\s]*))\))))?(?:\{.*\})?)?
\s*(?:(?:client\s)?[\(\{\[]+([^\)\}\]]*)[\)\}\]]+\;?(?:\{.*\})?)?
(?:[\s\n]*)
(?:\s*(?:by(?:(?:.*?)(?:\;|(?:[\r\n]+))))(?!.*with))?
(?:\s*(?:by\s[^\;]*\)?)(?=.*with)\s*)?
(?:with\s*(?:((?:[^\n;]*))(?:.*\;)?))?
(?:[\s\n]*)?
(?:\(?envelope-from\s*([^\n]*)\;?\)?)?
(?:\s*id[^;]*\;?)?
(?:[\s\n]*)?
(?:for\s([^\;]*)\;)?
(?:[\s\n]*)?
(?:\(.*\)\;)?(?:[\s\n])?
([^\(]+)?
(?:\(?envelope-from\s*([^\n]*)\;?\)?)?/mxp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}