using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"clientName=(.*?)(?=\s*,\s*\w+=|\])";
string input = @"com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD LAW SCHOOL, THE, clientId=12345]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}