re = /clientName=(.*?)(?=\s*,\s*\w+=|\])/m
str = 'com.example.sensitive.info.UserInfo@15b1534[name=User1, clientName=HARVARD LAW SCHOOL, THE, clientId=12345]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end