use strict;
my $str = 'https://www.google.com/';
my $regex = qr/^(.*)google\.com((?!recaptcha).)*$/mp;
my $subst = '$';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";