$re = '/^(.*)google\.com((?!recaptcha).)*$/m';
$str = 'https://www.google.com/';
$subst = "$";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;