# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<link *.*(?: *href=\"([^\"]*(\.png|\.ico))\"| *type=\"(?:image\/png|image\/vnd\.microsoft\.icon|image\/x-icon)\"| *rel=\"(?:icon|shortcut icon|apple-touch-icon)\").*>"
test_str = ("<link rel=\"icon\" type=\"image/png\" href=\"https://static.production.thenounproject.com/img/favicons/favicon-16x16.0b6183ac3673.png\" sizes=\"32x32\" />\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.