re = /<link *.*(?: *href="([^"]*(\.png|\.ico))"| *type="(?:image\/png|image\/vnd\.microsoft\.icon|image\/x-icon)"| *rel="(?:icon|shortcut icon|apple-touch-icon)").*>/im
str = '<link rel="icon" type="image/png" href="https://static.production.thenounproject.com/img/favicons/favicon-16x16.0b6183ac3673.png" sizes="32x32" />
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end