using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\h*\d+(?:\h+\d+)*\h*$";
string input = @"1
2 3
3 56
8888888 333
039
not OK:
a
4 e
874 1231 88 qqqq 99
shf ie sh f 8";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}