import re
regex = re.compile(r"^\h*\d+(?:\h+\d+)*\h*$", flags=re.MULTILINE)
test_str = ("1\n"
"2 3\n"
" 3 56 \n"
"8888888 333\n"
" 039\n\n"
"not OK:\n\n"
"a\n"
"4 e\n"
"874 1231 88 qqqq 99\n"
" shf ie sh f 8")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")