const regex = /^[6-9](?!\d*(\d)\1{4})\d{9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[6-9](?!\\d*(\\d)\\1{4})\\d{9}$', 'gm')
const str = `9999999999
6666677777
6612377890
6912345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}