$re = '/^[6-9](?!\d*(\d)\1{4})\d{9}$/m';
$str = '9999999999
6666677777
6612377890
6912345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);