package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i).co$`)
var str = `abcd@email.co.uk
mbd@exmaple.co.in
abcd@email.co
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}