$re = '/(?i).co$/m';
$str = 'abcd@email.co.uk
mbd@exmaple.co.in
abcd@email.co
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);